preferencemanager is deprecated
snippet in kotlin

preferencemanager is deprecated

user5337

//You can use AndroidX support library version of PreferenceManager
androidx.preference.PreferenceManager
//not 
android.preference.PreferenceManager
//remember to add the following to your build.gradle if needed
implementation 'androidx.preference:preference:1.1.1'